有学有练才叫学习:学而不思则罔,思而不学则殆:学而不习,纸上谈兵,习而不进,画地为牢!

antd按需加载(antd按需加载配置)详细配置

前端框架 炮渣日记 4周前 (11-13) 21次浏览 已收录 0个评论 扫描二维码

antd按需加载配置

1.npm run eject 拉取react配置文件

拉取配置文件失败报错: Remove untracked files, stash or commit any changes, and try again.
问题解释: 因为更改了create-react-app原本的项目结构, 需要重新将代码提交至仓库
解决方法: 将.git文件删除后, 再执行 npm run eject

2.npm install babel-plugin-import –save-dev

参考地址: https://github.com/ant-design/babel-plugin-import

3.配置package.json

"babel": { "presets": [ "react-app" ], "plugins": [ [ "import", { "libraryName": "antd", "libraryDirectory": "es","style": "css" } ] ] }
喜欢 (0)
炮渣日记
关于作者:
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址